Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#3545 closed Defect (Invalid)

No Chat Window

Reported by: hragatron@… Owned by:
Component: Colloquy (Mac) Version: 2.4 (Mac)
Severity: Major Keywords: window not opening
Cc:

Description

When running Colloquy, I can connect to our server, but the main chat window doesn't appear at all. There were no changes on my end, it was working the previous night then in the morning I re-connected, but the chat window wasn't updating. Then I quit, re-started with no luck. Rebooted machine with no luck. Re-installed and reset preferences, also with no luck.

Here's what console said:

3/13/13 12:19:34.409 PM Colloquy[974]: -[NSCFString characterAtIndex:]: Range or index out of bounds

3/13/13 12:19:34.410 PM Colloquy[974]: (

0 CoreFoundation? 0x00007fff8e8670a6 exceptionPreprocess + 198
1 libobjc.A.dylib 0x00007fff92bc63f0 objc_exception_throw + 43
2 CoreFoundation? 0x00007fff8e866e7c +[NSException raise:format:] + 204
3 CoreFoundation? 0x00007fff8e82b8ee -[
NSCFString characterAtIndex:] + 94
4 ChatCore? 0x000000010fdc623a -[MVIRCChatConnection(MVIRCChatConnectionPrivate) _sendCommand:withArguments:withEncoding:toTarget:] + 906
5 Colloquy 0x000000010fbe8a35 -[JVChatConsolePanel send:] + 2273

)
3/13/13 12:19:36.633 PM Colloquy[974]: -[NSCFString characterAtIndex:]: Range or index out of bounds

3/13/13 12:19:36.634 PM Colloquy[974]: (

0 CoreFoundation? 0x00007fff8e8670a6 exceptionPreprocess + 198
1 libobjc.A.dylib 0x00007fff92bc63f0 objc_exception_throw + 43
2 CoreFoundation? 0x00007fff8e866e7c +[NSException raise:format:] + 204
3 CoreFoundation? 0x00007fff8e82b8ee -[
NSCFString characterAtIndex:] + 94
4 ChatCore? 0x000000010fdc623a -[MVIRCChatConnection(MVIRCChatConnectionPrivate) _sendCommand:withArguments:withEncoding:toTarget:] + 906
5 Colloquy 0x000000010fbe8a35 -[JVChatConsolePanel send:] + 2273

)

Change History (6)

comment:1 Changed 7 years ago by zach

  • Resolution set to Works for Me
  • Status changed from new to closed

Is this still happening? I can't reproduce.

comment:2 Changed 6 years ago by scott.gardner@…

I am experiencing the same issue, version 2.4.2 on OS X 10.8.4.

comment:3 Changed 6 years ago by scott.gardner@…

  • Resolution Works for Me deleted
  • Status changed from closed to reopened

comment:4 Changed 6 years ago by scott.gardner@…

Chat window finally appeared for me after a few minutes.

comment:5 Changed 6 years ago by zach

  • Resolution set to Invalid
  • Status changed from reopened to closed

comment:6 Changed 6 years ago by anonymous

Same issue here... Version 2.3 (4617)

But I guress I'm lost, because I am still running Snow Leopard and Colloquy Version 2.3 (4617)

Note: See TracTickets for help on using tickets.